另类ROS智能限速让限速更稳定更智能 | 百味人生
最新消息:我来了,你来了吗

另类ROS智能限速让限速更稳定更智能

心得摘录 百味人生 1567浏览 0评论

测 试  人:tsee123

测试版本:ROS 2.9.6

测试环境:4M光纤  50个客户机

测试效果:普通速度没人1M,总网速到达3.8M以后自动触发脚本把网速降为60K

在网上找到很多同样的脚本,但是每次都不能全部执行。可能是应为版本不同吧,这个是我根据网上找的又一边测试一边修改的。总是算是搞定了!

=======================================================================
1.这个是建立静态限速,1to254 改为你内网的IP!比如 2 to 120!  192.168.0. 这里改为你的IP段!      limit-at=50000/50000  是平均网速50K,max-limit=1000000/1000000 是普通限速1M!

:for aaa from 1 to 254 do={/queue simple add name=(PC . $aaa) dst-address=(192.168.0. . $aaa) limit-at=50000/50000 max-limit=100000/100000}

=======================================================================
2.这个是固定脚本,直接复制运行。
/ ip firewall mangle
add chain=prerouting action=mark-packet new-packet-mark=all-mark \
    passthrough=yes comment="" disabled=no

=======================================================================
3.这里把60000改为你动态限速时的全网上传速度和下载速度!其他不要改!这里是60k!

/ queue type
add name="PCQ-up" kind=pcq pcq-rate=60000 pcq-limit=50 \
    pcq-classifier=src-address pcq-total-limit=2000
add name="PCQ-down" kind=pcq pcq-rate=60000 pcq-limit=50 \
    pcq-classifier=dst-address pcq-total-limit=2000

=======================================================================
4.到这里就是建立动态限速的策略了!192.168.0.0/24 改为你IP段!
max-limit=400000/400000 这里是你总宽带,电信给你多少就填多少!其他不用改,
因为需要转跳到上面的!
/ queue simple
add name=PCQ target-addresses=192.168.0.0/24 dst-address=0.0.0.0/0 interface=all parent=none packet-marks=all-mark, priority=1 queue=PCQ-up/PCQ-down limit-at=0/0 max-limit=400000/40000 total-queue=default disabled=yes

=======================================================================
5.这个是启发脚本,就是启发动态和关闭动态的脚本!直接复制!

/ system script
add name="PCQON" source=":if \(\[ /queue sim get \[/queue sim find \
    name=\"PCQ\"\] disable \]=true \) do={/queue sim enable PCQ}" \
    policy=ftp,reboot,read,write,policy,test,winbox,password
add name="PCQOFF" source=":if \(\[ /queue sim get \[/queue sim find \
    name=\"PCQ\"\] disable \]=false \) do={/queue sim disable PCQ}" \
    policy=ftp,reboot,read,write,policy,test,winbox,password

========================================================================
6.流量监控触发

 流量监控设置的是3.8M(你的带宽总流量)开启、3M关闭。把wlan换成你对应外网卡名字

/ tool traffic-monitor
 
add name="PCQON" interface=wlan traffic=received trigger=above \
    threshold=3800000 on-event=PCQON comment="" disabled=no
add name="PCQOFF" interface=wlan traffic=received trigger=below \
    threshold=3000000 on-event=PCQOFF comment="" disabled=no
=========================================================================

 

=========================================================================

/system scheduler add name=timeon interval=24h start-time=08:00:00 on-event={PCQON} disabled=no

/system scheduler add name=timeoff interval=24h start-time=23:59:59 on-event={PCQOFF} disabled=no

=========================================================================

把最后一段替换成这段就是由时间段控制开关PCQ了!
 

发表我的评论
取消评论

表情

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址